« Bugzilla Issues Index
#1281 — CheckObjectCoercible(this value)
- bug_id:
1281
- creation_ts:
2013-03-09 15:26:00 -0800
- short_desc:
CheckObjectCoercible(this value)
- delta_ts:
2013-08-21 14:13:48 -0700
- product:
Draft for 6th Edition
- component:
technical issue
- version:
Rev 14: March 8, 2013 Draft
- rep_platform:
All
- op_sys:
All
- bug_status:
RESOLVED
- resolution:
WORKSFORME
- priority:
Normal
- bug_severity:
enhancement
- everconfirmed:
true
- reporter:
Rick Waldron
- assigned_to:
Allen Wirfs-Brock
- cc:
waldron.rick
- commentid:
3411
- comment_count:
0
- who:
Rick Waldron
- bug_when:
2013-03-09 15:26:23 -0800
Does it make sense for this to simply be:
CheckObjectCoercible(this)
The semantics remain intact, while being consistent with other abstract operation calls
- commentid:
4338
- comment_count:
1
- who:
Allen Wirfs-Brock
- bug_when:
2013-06-30 13:37:26 -0700
not really. We try to never use just "this" as a meta-variable name in the algorithms, while "this value" has a specific meaning. I'd have to add a step like:
Let O be the this value.