archives

« Bugzilla Issues Index

#1281 — CheckObjectCoercible(this value)


Does it make sense for this to simply be:

CheckObjectCoercible(this)

The semantics remain intact, while being consistent with other abstract operation calls


not really. We try to never use just "this" as a meta-variable name in the algorithms, while "this value" has a specific meaning. I'd have to add a step like:
Let O be the this value.