The spec is inconsistent on using "strict mode" vs just "strict". E.g.:
1 "strict mode binding" vs 4 "strict binding"
48 "strict mode code" vs 36 "strict code"
1 "strict mode variant" vs 6 "strict variant"
Personally, I'd say drop "mode":
(1) You don't need it.
(2) A one-word adjective is simpler than a two-word adjectival phrase.
(3) Phrases like "non-strict mode functions" read (at first glance) like
(non-strict) (mode functions)
rather than
non-(strict mode) functions
(4) To me, the strict variant doesn't seem like a 'mode' anyway.
fixed in rev36 editor's draft
"strict binding" is has a distinct meaning, separate from "strict mode". Eliminated the 1 occurrence of "strict mode binding"
"strict variant" is only used in 4.2.2. Eliminate the one occurrence of "strict mode variant"
In 9.2 defined the terms "strict function" and "non-strict" function
In 10.2.1 defined the term "non-strict code" meaning code that is not strict mode code.
Update rest of spec. text to use those terms.
in rev36