In the following sections, I believe the word "character" should be replaced with the phrase "code unit". (Sometimes it isn't a simple find+replace, e.g. change
"the character whose code unit value is X"
"the code unit whose value is X".)
11.1.5 / Static Semantics: PropName
11.1.9 / Runtime Semantics: Evaluation / rules 5+6
11.8.1 / Runtime Semantics: The Abstract Relational Comparison Algorithm
11.9.1 / Runtime Semantics: The Strict Equality Comparison Algorithm
15.1.3 / Runtime Semantics: Encode Abstract Operation
15.1.3 / Runtime Semantics: Decode Abstract Operation
B.1.2 / Static Semantics
... and in 7.8.4 / Static Semantics: SV’s and CV’s,
where it says
The CV of ... is the empty character sequence.
... the character whose code unit value is ...
fixed in rev26 editors draft
did a sweep over the entire document for places where character could be replaced with code unit or code point.
fixed in rev26